Hi From London England

Introduce yourself here!
User avatar
Ruptor
Trump Card
Posts: 177
Joined: Fri Dec 20, 2019 2:23 pm

Re: Hi From London England

Postby Ruptor » Fri Dec 27, 2019 12:57 pm

I am starting to wonder if it stopped working and that is why I stopped using it since I usually run things until they break and can't be fixed any more.


User avatar
Chr$
Super Gold Card
Posts: 545
Joined: Mon May 27, 2019 10:03 am
Location: Sachsen, Germany

Re: Hi From London England

Postby Chr$ » Fri Dec 27, 2019 5:10 pm

Post a pic of the screen display, maybe someone will recognise the nature of the problem.


Collector of original and some newer QL related computers, accessories and software even though I don't understand how any of them work.
Original BBQL's: 3x German, 1x UK model (plus quite a bit of other old stuff)
Custom AT cased QL system with Gold Card, Qimi mouse, Hermes and MFM HDD
PC with QXLII card installed
Q68 also present

Ask me about near NOS re-felted good quality Microdrive Carts - many available.
User avatar
Ruptor
Trump Card
Posts: 177
Joined: Fri Dec 20, 2019 2:23 pm

Re: Hi From London England

Postby Ruptor » Fri Dec 27, 2019 8:21 pm

There is a half inch black band at the bottom of the pictures so the bottom should be straight seen better in the Bootup one but the camera angle makes it look curved. It is not so easy to take a picture and hold the button at the same time. The scan lines can be ignored because they varied with the position of the phone camera perhaps due to both the screen and camera having scans I think. :? I guess the RF and video is working but getting crap from the memory meaning there is either crap in the memory or what reads it is reading crap. Having said that it is probably unlikely the memory would all be the same at green if it was filled with zeros or random data so it points to what ever reads the video memory getting the same value regardless of what the memory contains. What does the reset hold say? It has changed the columns of dots and yet they resume the same pale green state when it is released. :? :? :? What happens on a working QL screen when the button is held because that might give a pointer.
Attachments
Bootup.jpg
InReset.jpg


Derek_Stewart
QL Wafer Drive
Posts: 1914
Joined: Mon Dec 20, 2010 11:40 am
Location: Runcorn, Cheshire, UK

Re: Hi From London England

Postby Derek_Stewart » Fri Dec 27, 2019 9:52 pm

Hi,

Have you tested the plugin chips: 8301, 8302, 8049, 68008.

Your problem could the 8301 not working correctly.

Memory failures cause a specific screen display colour on QDOS QL, Minvera can identify internal ram ptoblems.


Regards,

Derek
User avatar
tofro
Font of All Knowledge
Posts: 2014
Joined: Sun Feb 13, 2011 10:53 pm
Location: SW Germany

Re: Hi From London England

Postby tofro » Fri Dec 27, 2019 10:20 pm

Have you removed and re-seated the chips as said above?


ʎɐqǝ ɯoɹɟ ǝq oʇ ƃuᴉoƃ ʇou sᴉ pɹɐoqʎǝʞ ʇxǝu ʎɯ 'ɹɐǝp ɥO
User avatar
Ruptor
Trump Card
Posts: 177
Joined: Fri Dec 20, 2019 2:23 pm

Re: Hi From London England

Postby Ruptor » Sat Dec 28, 2019 10:28 am

Derek_Stewart wrote:Have you tested the plugin chips: 8301, 8302, 8049, 68008. Your problem could the 8301 not working correctly.
How do I test those chips. :? They want £17 for a x8301 on EBay & sellmyretro. :o
tofro wrote:Have you removed and re-seated the chips as said above?
Yes as in the last post on the previous page but no corrosion all shiny.
It would be useful if the posts were numbered.


User avatar
Chr$
Super Gold Card
Posts: 545
Joined: Mon May 27, 2019 10:03 am
Location: Sachsen, Germany

Re: Hi From London England

Postby Chr$ » Sat Dec 28, 2019 12:23 pm

Ruptor wrote:How do I test those chips. :? They want £17 for a x8301 on EBay & sellmyretro. :o

You know what you need to do....

Buy a known working complete QL and use it as a temporary donor to swap the socketed chips one by one until you hopefully find where the problem is. Then you can buy the correct replacement without wasting money on stuff you don't need and then sell one of the complete QL's. It's a bit time intensive, but that's what I usually do - the number of times I've bought whole obscure computers just in order to test out and fix up other odd computers! Problem is, I often end up keeping them all.


Collector of original and some newer QL related computers, accessories and software even though I don't understand how any of them work.
Original BBQL's: 3x German, 1x UK model (plus quite a bit of other old stuff)
Custom AT cased QL system with Gold Card, Qimi mouse, Hermes and MFM HDD
PC with QXLII card installed
Q68 also present

Ask me about near NOS re-felted good quality Microdrive Carts - many available.
User avatar
Ruptor
Trump Card
Posts: 177
Joined: Fri Dec 20, 2019 2:23 pm

Re: Hi From London England

Postby Ruptor » Sat Dec 28, 2019 1:33 pm

Or find a sucker I mean a nice person with a working one that will let me take it apart. :lol: If I bought a working one I could put the other in the bin and then what would I tinker with? I could still do some tests like check if the processor is running correctly by getting it to do something I could see on a pin. I guess put some test code in a boot ROM which is what I would do with a new design of hardware at work. The 80's was the start of the throw away culture with the advent of PALs & complex GALs allowing cheap custom circuits that couldn't be fixed only replaced I guess. :roll:


RWAP
RWAP Master
Posts: 2731
Joined: Sun Nov 28, 2010 4:51 pm
Location: Stone, United Kingdom
Contact:

Re: Hi From London England

Postby RWAP » Sun Dec 29, 2019 7:19 pm

Ruptor wrote:
Derek_Stewart wrote:Have you tested the plugin chips: 8301, 8302, 8049, 68008. Your problem could the 8301 not working correctly.
How do I test those chips. :? They want £17 for a x8301 on EBay & sellmyretro. :o


Unfortunately, the ZX8301 prices have increased over the past few years as the stocks are now extremely low. For example, the 28 I have remaining on sellmyretro are the end of the stock from Tony Firshman, who was the main source of QL repairs and spare chips..... Once they are gone, there is no current replacement.


User avatar
Ruptor
Trump Card
Posts: 177
Joined: Fri Dec 20, 2019 2:23 pm

Re: Hi From London England

Postby Ruptor » Mon Dec 30, 2019 5:32 pm

Anywhere there is hand soldering I always suspect first so I pulled out the 8302 to see what would happen with it missing. From a quick scan of the documentation it looked like it wasn't involved with the display. It totally changed the screen from a plain pale green to columns of predominantly white through grey to blue that regularly change as if being written. After soldering back the wire mod to the two resistors I plugged different combinations of the JM ROM chips and when IC33 is put in IC34 with IC33 empty the screen gives perfect bars with what looks like code altered dots that go up a column of pixels. It seems to me the video chip is working since it displays the altered memory state even though crap is being continuously put in the memory. This means the problem is the cpu to memory interface. The cpu is running because different things happen with the ROMs swapped about so it could be a corrupt program that I could test by verifying the ROMs or a bus problem either address or data.



Who is online

Users browsing this forum: No registered users and 1 guest