qlayw and Turbo Basic

Discussion and advice about emulating the QL on other machines.
gregtaylor
ROM Dongle
Posts: 33
Joined: Thu Aug 13, 2015 12:42 pm
Location: East Yorkshire
Contact:

qlayw and Turbo Basic

Postby gregtaylor » Thu Aug 13, 2015 3:40 pm

Hi,

I have been hitting my head on the screen trying to use Turbo Basic on the qlayw emulator. Commands are as follows:

DATA_USE WIN7_
PROG_USE WIN7_
DIR
(SHOWS DIRECTORY OF CORRECT TURBO BASIC FILES)
LOAD TEST_BAS
CHARGE
(RETURNS BAD PARAMETER)
EXEC PARSER_TASK
(RETURNS BAD PARAMETER)

The bad parameter error seems to imply the entry point for the program is being found. I cannot understand the bad parameter error as I was not sure it even needed one!
I have tried with the Minerva and the JS ROM and only the Toolkit2 ROM.

Has anyone any solution?

Many thanks

Greg (frustrated :x )


Derek_Stewart
QL Wafer Drive
Posts: 1365
Joined: Mon Dec 20, 2010 11:40 am
Location: Runcorn, Cheshire, UK

Re: qlayw and Turbo Basic

Postby Derek_Stewart » Thu Aug 13, 2015 6:15 pm

Hi,

Have you load Turbo Toolkit supplied with Turbo


Regards,

Derek
gregtaylor
ROM Dongle
Posts: 33
Joined: Thu Aug 13, 2015 12:42 pm
Location: East Yorkshire
Contact:

Re: qlayw and Turbo Basic

Postby gregtaylor » Thu Aug 13, 2015 7:07 pm

Yes, I have replaced file from a new download to ensure a matched set. I have also set the turbo basic windows disk to be win1_ and ensured boot was to a "clean" QL. I still get the bad parameter error.


Derek_Stewart
QL Wafer Drive
Posts: 1365
Joined: Mon Dec 20, 2010 11:40 am
Location: Runcorn, Cheshire, UK

Re: qlayw and Turbo Basic

Postby Derek_Stewart » Thu Aug 13, 2015 7:34 pm

Hi,

I used QLAY2 see attached screen shot.

Just LRESPRed Turbo_TK_Code and was in the Turbo subdirectory, entered Charge...

You must have a corrupted Turbo Distro.

You could try, entering:

EXEC parser_task

This will load the Turbo Parser

And when Parsing done, enter: EXEC codegen_task

Will generate the executable compliled programme.

Why not use QPC2...
Attachments
QLAY2.png
Turbo Under QLAY2 (Linux/Wine)


Regards,

Derek
EmmBee
Brittle Membrane
Posts: 100
Joined: Fri Jan 13, 2012 5:29 pm
Location: Kent

Re: qlayw and Turbo Basic

Postby EmmBee » Thu Aug 13, 2015 7:37 pm

Hi Greg, Derek,

The bad parameter error is from the EXEC command, which is not recognising PARSER_TASK as an executable file. You could try using the SEXEC command to re save these files as executable files. So, do something along these lines ...

COPY PARSER_TASK TO PARSER_TASK_old
lenf = FLEN(\PARSER_TASK)
base = RESPR(lenf)
LBYTES PARSER_TASK, base
SEXEC_O PARSER_TASK, base, lenf, 51200

Doing the above would re save the file with a dataspace of 50k, after which both CHARGE and EXEC PARSER_TASK should work.

Kind regards,
EmmBee


gregtaylor
ROM Dongle
Posts: 33
Joined: Thu Aug 13, 2015 12:42 pm
Location: East Yorkshire
Contact:

Re: qlayw and Turbo Basic

Postby gregtaylor » Thu Aug 13, 2015 8:52 pm

Thanks EmmBee, that sorted it. I shall have to remember that trick.

Derek, thanks. Will try QPC2 some time as well.

Greg


User avatar
tofro
QL Wafer Drive
Posts: 1578
Joined: Sun Feb 13, 2011 10:53 pm
Location: SW Germany

Re: qlayw and Turbo Basic

Postby tofro » Thu Aug 13, 2015 9:06 pm

gregtaylor wrote:....shall have to remember that trick.


No, you shouldn't ;)

You should instead remember that you should never un-zip a zip file intended for the QL anywhere else but on the QL - or emulator. In this case you will never again lose a file header in transit.

Explanation on that is on Dillwyn's web site.

Regards,
Tobias


ʎɐqǝ ɯoɹɟ ǝq oʇ ƃuᴉoƃ ʇou sᴉ pɹɐoqʎǝʞ ʇxǝu ʎɯ 'ɹɐǝp ɥO
gregtaylor
ROM Dongle
Posts: 33
Joined: Thu Aug 13, 2015 12:42 pm
Location: East Yorkshire
Contact:

Re: qlayw and Turbo Basic

Postby gregtaylor » Fri Aug 14, 2015 6:31 pm

Thanks to you both. Turbo is now working perfectly in qlayw. Have been enjoying doing some benchmark programs to test the performance upgrade. All I need to do now is to sit down and read the rest of the manual. ;)

Greg



Who is online

Users browsing this forum: No registered users and 3 guests