Page 1 of 1

Hi from New Zealand

Posted: Tue Jul 27, 2021 9:00 am
by maigretnz
I got my QL in the UK in 1990.

It has been in storage since 1996 but now would like to get it running again.

Something not working. Almost, so I am working on fault finding.

Graeme

Re: Hi from New Zealand

Posted: Tue Jul 27, 2021 9:17 am
by vanpeebles
Hello! Hopefully get that QL up and running :)

Re: Hi from New Zealand

Posted: Tue Jul 27, 2021 1:19 pm
by NormanDunbar
Greetings! And Welcome.

Can we have your Prime Minister please? Our one is broken. ;)

Cheers,
Norm.

Re: Hi from New Zealand

Posted: Tue Jul 27, 2021 5:31 pm
by dilwyn
NormanDunbar wrote:Greetings! And Welcome.
Can we have your Prime Minister please? Our one is broken. ;)
Cheers,
Norm.

Broken? I don't remember him ever being in working order ?!?! :roll:

Re: Hi from New Zealand

Posted: Wed Jul 28, 2021 9:46 am
by NormanDunbar
Good point Dilwyn, and well made.

Hope you are well.

Cheers,
Norm.

Re: Hi from New Zealand

Posted: Thu Nov 25, 2021 5:14 am
by maigretnz
Making some progress after getting a Minerva ROM but most RAM showing faulty randomly.
Have ordered a ULA chip IC22 to see if that works

Re: Hi from New Zealand

Posted: Thu Nov 25, 2021 7:53 am
by vanpeebles
maigretnz wrote:Making some progress after getting a Minerva ROM but most RAM showing faulty randomly.
Have ordered a ULA chip IC22 to see if that works


Keep up the good work :)

Re: Hi from New Zealand

Posted: Thu Nov 25, 2021 9:17 pm
by Ruptor
maigretnz wrote:Making some progress after getting a Minerva ROM but most RAM showing faulty randomly.
Have ordered a ULA chip IC22 to see if that works
Have you checked other threads of people repairing QLs? There are lots of fundamental things to check like corrosion & chip seating. If your QL was working when you stored it a chip death seems unlikely unless it hit sub zero temperatures.
One of the experts should stick a sticky up of the most common problems & fixes.

Re: Hi from New Zealand

Posted: Fri Nov 26, 2021 7:49 am
by tofro
If you get a (whatever fancy) picture and the QL starts up to execute ROM code (shown by Minerva coming up with a RAM error), it's very unlikely that any of the ULAs is faulty. The QL ULAs are not known as being particularily robust (that means, they do actually die), but if they do, it's rather nothing at all than partially working.