Problems printing from QPC to QPCPrint

Anything QL Software or Programming Related.
User avatar
QL Wafer Drive
Posts: 1958
Joined: Sun Feb 13, 2011 10:53 pm
Location: SW Germany

Problems printing from QPC to QPCPrint

Postby tofro » Wed Aug 28, 2019 10:52 am


before bothering Marcel, who seems to be on vacation:

I have some problems on a fairly recent installation of QPC and QPCPrint on a Windows 10 machine:

  • SMSQ/E 3.34
  • QPC 4.93 (wonder where I got that from, Marcel's site seems to offer an older version.)
  • QPCPrint 1.03 (in case that matters)

QPCPrint is configured properly to PAR1, "Filter" is checked

SPL <someFile> TO par1 simply crashes QPC2. After terminating the crashed instance, QPCPrint comes up with a partial print with a lot of stuff missing at the end

OPEN #4,par1:LIST#4:CLOSE #4 Prints part of the file, but with missing parts arbitrarily spread over the print

Someone had similar experiances and how did you solve it?

Another quirk: I Tried to change the default printer in the QPCPrint setup dialog, but the displayed setting reverts back to "Microsoft Fax" all the time (even if QPCPrint prints nicely to the configured printer)


ʎɐqǝ ɯoɹɟ ǝq oʇ ƃuᴉoƃ ʇou sᴉ pɹɐoqʎǝʞ ʇxǝu ʎɯ 'ɹɐǝp ɥO
Posts: 1631
Joined: Wed Dec 01, 2010 10:39 pm

Re: Problems printing from QPC to QPCPrint

Postby dilwyn » Wed Aug 28, 2019 12:30 pm

Hi Tobias,
I'm using QPC2 4.94/SMSQ-E 3.34 (version which Marcel sent me on 13/4/19 (there has been another Beta in early August which implements a sound chip emulation, but I haven't tried that one yet). 3.93 was issued as a Beta earlier in the month for some issue relating to laptop sleep mode. I think the version on Marcel's site is the most recent official release, the others being Beta tests not yet ready for release (as you seem to be finding out!)

I don't use QPCprint so can't help with that one.I can confirm that printing *without* using Filter seems to work OK, no missing bits of text on my test printout.

Configuration screen - I have three printers here, a very old Epson Stylus 880 (also used with QL), A HP Deskjet 3050 (used for work) and a Brother MFC-J6510DW (my son's printer). Printing seems to work OK, but as you mentioned, the PAR configuration seems to always revert to same printer, but printing seems to work on PAR1 and PAR2; can't test PAR3 at the moment as the Brother printer isn't connected. i.e. PAR1 to PAR3 all show the Brother printer, but seem to print to where I last saved the configuration.

User avatar
Super Gold Card
Posts: 600
Joined: Sun Feb 02, 2014 10:54 am
Location: Esslingen/Germany

Re: Problems printing from QPC to QPCPrint

Postby mk79 » Wed Aug 28, 2019 2:20 pm

I'm not yet on holiday, but soon. Regarding the crash, you should have gotten a mail with a later beta a month ago, please retest with that. I remember there was a problem, I just don't know exactly in which version.

And yes, the printer selection in the config dialog is broken, thanks for noticing. But this is a dialog problem only, if you save a specific printer that printer will be used. It will just not be re-selected when you re-enter the PAR dialog.

Cheers, Marcel

Who is online

Users browsing this forum: No registered users and 4 guests