New (to me) Q40!

The Thor, Aurora, Q40, Q60 & Q68 etc. are discussed here.
User avatar
Derek_Stewart
Font of All Knowledge
Posts: 2139
Joined: Mon Dec 20, 2010 11:40 am
Location: Runcorn, Cheshire, UK

Re: New (to me) Q40!

Postby Derek_Stewart » Sat Dec 26, 2020 4:56 pm

RalfR wrote:Seems to be a quality problem of the PCB. I have had never such problems with PC mainboards when inserting RAM modules or ISA cards.

Derek_Stewart wrote:Hi,

The purpose of the rubber feet is an attempt, to support the PCB from be flexed from inerstion of a Card into the ISA sockets.

I have repaired Q40 boards were there has been damage to the internal circuit traces, around the ISA connectors.

There should also be support under the Rom and Ram Sockets, which may also introduce flexing of the PCB, when inserting ram modules.

Hi Ralf,

In my experience of repairing PCs, it is the quality of the components connected to the motherboard. There was many rubbish components fitted to motherboards, I replaced many failed boards due user downward pressure on the ISA/PCI/RAM sockets.

The Q40 board depicted above does show this problem, Photo 1 & 4 show the ISA connectors from different suppliers, which introduce a problem of the insertion of the ISA Card into the sockets. The sockets are supposed to be uniform, but this not the case.

My Qbranch Q40, the inner ISA socket end broke, which required a new socket. Of course I went back to the Q40 manufacturer, would say it was my fault, then wrote lies in QLToday. So replacing the complete ISA connectors made the Q40 functional.

So not the PCB design, the cheap and nasty components fitted.

The Q60 PCB design, is the same as the Q40 PCB design. No Q60 board ever failed like this.

Just to finalise all this bad feeling, the Q40, in theory can be converted to a Q60, with additional of extra components, I tried to convert my Q40 board to Q60.

Needless to say the upgrade did not work, mainly due the quality of the components used to build the Q40. I was best placed to judge this because of the experience of building the Q60.

I am surprised that this Q40 board actually works. At least they got some right....

I shall not mention the Q40 fiasco ever again.


Regards,

Derek
User avatar
RalfR
Super Gold Card
Posts: 520
Joined: Fri Jun 15, 2018 8:58 pm

Re: New (to me) Q40!

Postby RalfR » Sat Dec 26, 2020 5:45 pm

Derek_Stewart wrote:So not the PCB design, the cheap and nasty components fitted.
Oh no, I do not mean the design (of course not). I have seen, that the ISA connectors were from different manufacturers. No problem, if they are in good quality, but as you have written, they are not.

Perhaps it would be worth a try to get them from the same source as Marcel's VGA. He seems to be very satisfied with them.


User avatar
Derek_Stewart
Font of All Knowledge
Posts: 2139
Joined: Mon Dec 20, 2010 11:40 am
Location: Runcorn, Cheshire, UK

Re: New (to me) Q40!

Postby Derek_Stewart » Sat Dec 26, 2020 7:46 pm

RalfR wrote:Perhaps it would be worth a try to get them from the same source as Marcel's VGA. He seems to be very satisfied with them.

Hi, Ralf,

Thanks for the advice, but I did not make the Q40...


Regards,

Derek
User avatar
Peter
QL Wafer Drive
Posts: 1195
Joined: Sat Jan 22, 2011 8:47 am

Re: New (to me) Q40!

Postby Peter » Mon Dec 28, 2020 1:48 pm

RalfR wrote:
Derek_Stewart wrote:So not the PCB design, the cheap and nasty components fitted.
Oh no, I do not mean the design (of course not). I have seen, that the ISA connectors were from different manufacturers. No problem, if they are in good quality, but as you have written, they are not.

Perhaps it would be worth a try to get them from the same source as Marcel's VGA. He seems to be very satisfied with them.

Does that have ISA sockets?



Who is online

Users browsing this forum: No registered users and 2 guests