QLSD driver testers sought

Nagging hardware related question? Post here!
User avatar
mk79
Trump Card
Posts: 217
Joined: Sun Feb 02, 2014 10:54 am

Re: QLSD driver testers sought

Postby mk79 » Mon Jul 23, 2018 8:22 pm

The new units will be available as soon as I‘m satisfied that the driver works ;) But the driver is also supposed to work with the old version, of course. Chip upgrades will be available then, too.

LRESPRing the .bin version is all you have to do to get started.

Cheers, Marcel


afx
Chuggy Microdrive
Posts: 69
Joined: Tue Dec 28, 2010 10:23 pm

Re: QLSD driver testers sought

Postby afx » Tue Jul 24, 2018 11:41 pm

mk79 wrote:…. But the driver is also supposed to work with the old version, of course. Chip upgrades will be available then, too.

LRESPRing the .bin version is all you have to do to get started.


Wow..., great!

The new driver version works perfectly on my QL-SD + GoldCard system. Now the system is very reliable and robust. I can finally share the .win containers between QPC2, Q68 and BBQL + GoldCard. I have mounted win1_ and win2_ in my BBQL+GoldCard with .WIN containers to massively transfer files between them. The result has been great, zero problems.

Marcel, a great job, congratulations !!


afx
Chuggy Microdrive
Posts: 69
Joined: Tue Dec 28, 2010 10:23 pm

Re: QLSD driver testers sought

Postby afx » Sat Jul 28, 2018 5:59 pm

Hi Marcel.

I have a small problem with the new 1.05 driver version. Specifically, the dev_use command does not seem to work on my system (QL-SD + GolCard 2.49), the computer remains blocked.

For example, the following instructions block the system.

Code: Select all

dev_use 3, win1_Prg_
dir dev3_


However, when the destination is not a win1_ resource then dev_use works fine. For example, the following instructions work correctly.

Code: Select all

dev_use 3, flp1_Prg_
dir dev3_


What could be the problem?

Cheers.


User avatar
mk79
Trump Card
Posts: 217
Joined: Sun Feb 02, 2014 10:54 am

Re: QLSD driver testers sought

Postby mk79 » Sun Jul 29, 2018 11:58 am

afx wrote:Marcel, a great job, congratulations !!
Thanks! That makes two happy users, looks like I can release this soon.
I have a small problem with the new 1.05 driver version. Specifically, the dev_use command does not seem to work on my system (QL-SD + GolCard 2.49), the computer remains blocked.
Ah yes, the DEV device included in the 2.49 GC-ROM is too old to handle the QL-SD driver. I've created a new ROM version for myself, but that is not ready for release. In the meantime you can just RESPR a newer version of the DEV device from here:
https://www.kilgus.net/soft/dev205.zip

All the best, Marcel


afx
Chuggy Microdrive
Posts: 69
Joined: Tue Dec 28, 2010 10:23 pm

Re: QLSD driver testers sought

Postby afx » Sun Jul 29, 2018 8:36 pm

mk79 wrote:That makes two happy users, looks like I can release this soon.

:D :D

mk79 wrote:Ah yes, the DEV device included in the 2.49 GC-ROM is too old to handle the QL-SD driver. I've created a new ROM version for myself, but that is not ready for release. In the meantime you can just RESPR a newer version of the DEV device from here:https://www.kilgus.net/soft/dev205.zip

I have tried load that DEV version but the system reports the message "not implemented yet" and then dev_use does not work.


Cheers.


User avatar
mk79
Trump Card
Posts: 217
Joined: Sun Feb 02, 2014 10:54 am

Re: QLSD driver testers sought

Postby mk79 » Sun Jul 29, 2018 11:45 pm

afx wrote:I have tried load that DEV version but the system reports the message "not implemented yet" and then dev_use does not work.
Just shows that no matter how sure you are that it will work, never release anything without testing it... turns out this is basically the SMSQ/E version of the code. It will load and work fine when you LRESPR hot_rext first. I have however removed the download until I have a real QDOS version of the DEV device going again.

Cheers, Marcel


afx
Chuggy Microdrive
Posts: 69
Joined: Tue Dec 28, 2010 10:23 pm

Re: QLSD driver testers sought

Postby afx » Mon Jul 30, 2018 11:05 am

Ok, clarified.

I have loaded SMSQ/E in my BBQL and now everything with DEV devices and QL-SD driver 1.05 work correctly.

Thank you Marcel for the support.

Cheers!


User avatar
mk79
Trump Card
Posts: 217
Joined: Sun Feb 02, 2014 10:54 am

Re: QLSD driver testers sought

Postby mk79 » Mon Jul 30, 2018 11:07 am

You’re welcome :)

Just to clarify, the DEV driver will work with QDOS, too, but it needs the Hotkey extension to initialise.
SMSQ/E already comes with a compatible version, of course.

Cheers, Marcel


User avatar
mk79
Trump Card
Posts: 217
Joined: Sun Feb 02, 2014 10:54 am

Re: QLSD driver testers sought

Postby mk79 » Mon Jul 30, 2018 11:14 pm

OK, this was rather more complicated than I anticipated. The problem is that this QL-SD driver is the first "Level 3" style driver ever developed for QDOS and Level 3 drivers expect that they can change the size of the channel definition block. This works well enough in QDOS, but Minerva "helpfully" restores the original CDB pointer, which is of course invalid now. The QL-SD driver already had special code in the OPEN routine to deal with this, but what I didn't anticipate is that the OPEN routine might not have been called directly from Minerva but from, for example, the DEV Open routine! This resulted in a crash or other odd behaviour.

So there is a new driver version 1.07 available at https://www.kilgus.net/soft/qlsd107_bin.zip
And there is now a QDOS version of the DEV device available again at https://www.kilgus.net/soft/dev205.zip

Thanks for checking it out. Cheers, Marcel


afx
Chuggy Microdrive
Posts: 69
Joined: Tue Dec 28, 2010 10:23 pm

Re: QLSD driver testers sought

Postby afx » Wed Aug 01, 2018 11:34 am

Great!

Now everything works correctly with Minerva too.

Cheers!



Return to “Hardware”

Who is online

Users browsing this forum: No registered users and 2 guests