Problem with making partitions

Nagging hardware related question? Post here!
User avatar
jivrt
Chuggy Microdrive
Posts: 61
Joined: Sun Feb 17, 2013 6:16 pm
Location: Puerto Varas, Chile

Re: Problem with making partitions

Postby jivrt » Thu Jul 05, 2018 2:22 am

Solved!

Reading the forum I found a post by Outsoft with the exact problem in a CF CARD: Fat is wrong

Thanks to Derek

Solved, thanks to Derek ;)

With this procedure:

WIN_DRIVE -1
WIN_FORMAT 3,4
WIN_DISK "REMOVE",1,1
WIN_DISK "CREATE",1,1,128
WIN_DRIVE 1,1,1
FORMAT "WIN1_WIN1"

Now please, if somebody has time...can you explain step by step why this procedure works and the first procedure doesn't. Has it someting to do with using ""?


Original BBQL 1985, bought my me in Spain with JM ROM
Tetroid TDI with CF card, ROM switcher, power regulator, Gold Card clone and Backplane
Uses: teaching my children to program
Derek_Stewart
QL Wafer Drive
Posts: 1113
Joined: Mon Dec 20, 2010 11:40 am
Location: Runcorn, Cheshire, UK

Re: Problem with making partitions

Postby Derek_Stewart » Thu Jul 05, 2018 9:09 am

Hi,

In the first message, you did not format the partition, where as in the second message you did. This could be the difference.

Basicall as you have found out, the exisiting parition have to be unloaded from a WIN drive number and can be reformatted or erased.

Try reading the QubATA manual, there is a good example on how t create partitions.


Regards,

Derek
User avatar
jivrt
Chuggy Microdrive
Posts: 61
Joined: Sun Feb 17, 2013 6:16 pm
Location: Puerto Varas, Chile

Re: Problem with making partitions

Postby jivrt » Thu Jul 05, 2018 7:25 pm

Thank you very much Derek

I completed reading the QubaTa manual for the second time today and with your explanation its much clearer.

Best Regards

Juan


Original BBQL 1985, bought my me in Spain with JM ROM
Tetroid TDI with CF card, ROM switcher, power regulator, Gold Card clone and Backplane
Uses: teaching my children to program
User avatar
jivrt
Chuggy Microdrive
Posts: 61
Joined: Sun Feb 17, 2013 6:16 pm
Location: Puerto Varas, Chile

Re: Problem with making partitions

Postby jivrt » Sat Jul 07, 2018 5:37 pm

After having succesfully formatted win1 now at reboot I keep having Fat is wrong messages.
Could it be that my SanDisk SDCFH-2048 is incompatible with the TDI?


Enviado desde mi iPhone utilizando Tapatalk


Original BBQL 1985, bought my me in Spain with JM ROM
Tetroid TDI with CF card, ROM switcher, power regulator, Gold Card clone and Backplane
Uses: teaching my children to program
User avatar
jivrt
Chuggy Microdrive
Posts: 61
Joined: Sun Feb 17, 2013 6:16 pm
Location: Puerto Varas, Chile

Re: Problem with making partitions

Postby jivrt » Sat Jul 07, 2018 5:40 pm

The other strange behaviour is that win_ver$ returns bad name and not the driver version


Enviado desde mi iPhone utilizando Tapatalk


Original BBQL 1985, bought my me in Spain with JM ROM
Tetroid TDI with CF card, ROM switcher, power regulator, Gold Card clone and Backplane
Uses: teaching my children to program
User avatar
jivrt
Chuggy Microdrive
Posts: 61
Joined: Sun Feb 17, 2013 6:16 pm
Location: Puerto Varas, Chile

Re: Problem with making partitions

Postby jivrt » Sat Jul 07, 2018 6:05 pm

I seem to have recovered the CF card using FORMAT 3,6 for 16 blocks.
As Jose Leandro states, the geometry is important to avoid the FAT is wrong issue
I still get a bad name with WIN_VER$


Enviado desde mi iPhone utilizando Tapatalk


Original BBQL 1985, bought my me in Spain with JM ROM
Tetroid TDI with CF card, ROM switcher, power regulator, Gold Card clone and Backplane
Uses: teaching my children to program
User avatar
jivrt
Chuggy Microdrive
Posts: 61
Joined: Sun Feb 17, 2013 6:16 pm
Location: Puerto Varas, Chile

Re: Problem with making partitions

Postby jivrt » Sat Jul 07, 2018 6:35 pm

Ok, after copying files to win1 and verify they work I restart the QL and again I have the fat is wrong message, unable to link win1
Lost the card again
Back to square 1


Enviado desde mi iPhone utilizando Tapatalk


Original BBQL 1985, bought my me in Spain with JM ROM
Tetroid TDI with CF card, ROM switcher, power regulator, Gold Card clone and Backplane
Uses: teaching my children to program
User avatar
jivrt
Chuggy Microdrive
Posts: 61
Joined: Sun Feb 17, 2013 6:16 pm
Location: Puerto Varas, Chile

Re: Problem with making partitions

Postby jivrt » Sun Jul 08, 2018 12:36 am

jivrt wrote:I seem to have recovered the CF card using FORMAT 3,6 for 16 blocks.
As Jose Leandro states, the geometry is important to avoid the FAT is wrong issue
I still get a bad name with WIN_VER$


Enviado desde mi iPhone utilizando Tapatalk

Solved: answer to myself
The correct syntax is version$=win_ver$


Enviado desde mi iPhone utilizando Tapatalk


Original BBQL 1985, bought my me in Spain with JM ROM
Tetroid TDI with CF card, ROM switcher, power regulator, Gold Card clone and Backplane
Uses: teaching my children to program
User avatar
jivrt
Chuggy Microdrive
Posts: 61
Joined: Sun Feb 17, 2013 6:16 pm
Location: Puerto Varas, Chile

Re: Problem with making partitions

Postby jivrt » Mon Jul 09, 2018 1:18 am

So the hardware problem continues

After tinkering for many days and reading the manual several times the problem comes to this

I have succesfully made 3 partitions of 256 MB on the 2GB CF card, using tetroid TDI.
I have copied files to each one.

When I reset the QL, half of the time I get a WIN1 link fail and FAT is wrong. If I do win_disk -1 and then load the win1 partition it says bad medium. Then if I load the first partition in win2_ it works fine. Then I unload it and load it in win1 and it works again.

The other half of the time WIN1 links perfectly at start up.

If I cant trust it to link win1 every time I can't have a reliable boot program in the CF card.

I can't figure out what is the problem that makes it link win1 only sometimes.

Is there something I'm doing wrong? Does it have to do with my JM ROM?


Original BBQL 1985, bought my me in Spain with JM ROM
Tetroid TDI with CF card, ROM switcher, power regulator, Gold Card clone and Backplane
Uses: teaching my children to program
User avatar
XorA
Super Gold Card
Posts: 552
Joined: Thu Jun 02, 2011 11:31 am
Location: Shotts, North Lanarkshire, Scotland, UK

Re: Problem with making partitions

Postby XorA » Mon Jul 09, 2018 7:02 am

What make of cf? Not all are equal.



Return to “Hardware”

Who is online

Users browsing this forum: No registered users and 2 guests