Page 1 of 3

uQLx 2018a

Posted: Mon Oct 29, 2018 11:18 am
by dilwyn
A further update of uQLx emulator for Linux systems is now available to download from the Emulators page on my website at http://www.dilwyn.me.uk/emu/index.html#uQLx_for_Linux_etc.. This is version 2018a.

In cases of difficulty remember it is also available from the backup site at Greybeardz.com http://www.greybeardz.com/emu/index.html#uQLx_for_Linux_etc.

The zip file includes 32-bit and 64-bit binaries, plus a uQLx manual as a PDF file, and a short README file detailing the changes made by Timothy Swenson.

Please remember that this is an UPDATE package only, so the original 'uQLx2017' remains on the page.

Thanks to Graeme Gregory for the original 2017 port and to Timothy Swenson for being ready to produce this update.

uqlx2018a.jpg
uQLx 2018a - cover page from manual.

Re: uQLx 2018a

Posted: Sat Nov 17, 2018 11:06 am
by Cristian
And thanks for your continuous dedication in updating and publicizing your website

Re: uQLx 2018a

Posted: Sat Dec 29, 2018 4:40 pm
by Tuna
Hmmm...

I've just installed uQLX under windows 10 Unix susystem and for some reason every other time I try to access a win_ drive (backed by a .win file) I get 'Not Found'.

So it'll work once, then fail, then work, then fail, then work. Doesn't seem to matter what the command is (dir, copy, lbytes, wcopy etc.). One fail, then work, then fail again...

Very odd..

Re: uQLx 2018a

Posted: Sat Jan 05, 2019 11:14 pm
by Tuna
Just as a follow up - the bug accessing win devices on uQLX under Windows Subsystem for Linux is specific to version 2018a - the older version without the TCP fix works just fine.

Re: uQLx 2018a

Posted: Sun Jan 06, 2019 10:32 pm
by XorA
Tuna wrote:Just as a follow up - the bug accessing win devices on uQLX under Windows Subsystem for Linux is specific to version 2018a - the older version without the TCP fix works just fine.


Sounds like the problem is probably there in 2017 but triggers slightly differently due to different compiler/libc or the like!

Re: uQLx 2018a

Posted: Mon May 20, 2019 5:31 pm
by tcat
Hi,

First of all, I wish to express my thanks for keeping `uQLx' alive. I run this emulator under `x86' and also `ARM'. On ARM (RPI) I migrated from Tobias' build to Graemme's, as I like its pixel scaling :-)

Found also sources on git `uqlx-fork', cloned to `/usr/local/src/ql' here.

`uqlx-2017' does things as it should, except I have some troubles executing turbo compiler, it gives.

Code: Select all

WARNING: could not patch Pointer Environment
Terminate on signal 11
This may be due to an internal error,
a feature not emulated or an 68000 exception
that typically occurs only when QDOS is unrecoverably
out of control
FATAL error, PC may not be displayed correctly
DebugInfo: PC=7e67e, code=4e43, SupervisorMode: no USP=7dbda SSp=28480 A7=7dbda
Register Dump:    Dn      An
0            70      70003
1            10      15cea
2          9536      146e6
3      ffffffff      146e6
4         6ade6      79266
5         79266      146e6
6             0      64b80
7             e      7dbda
*** Error in `./qm': double free or corruption (out): 0x0136e2d8 ***
exiting


I have also rebui;t from sources, just in case I missed some updates. (it needs CPU= setting in the .config, while no -m32 option, as ./configure does not seem to sense cpu).
Executing turbo gives the same report as above.

Tobias' build runs turbo no porblems here.

Anything I may have missed?

Many thanks in advance.
Tomas

Re: uQLx 2018a

Posted: Mon May 20, 2019 6:23 pm
by tofro
That looks like a trap #3, D0=$70 - iop.pinf call.

Apparently, uqlx detects the use of PE and tries to patch PE, but cannot find it. Actually iop.pinf is a call that should succeed (i.e. not crash, but rather return with a failure) even when PE is not loaded, as it's normally also used to detect if PE is present at all.

Try to load PE as a work-around.

Tobias

Re: uQLx 2018a

Posted: Mon May 20, 2019 7:06 pm
by tcat
Hi Tobias,

I set PE in ~/mdv1/boot as follows

100 LRESPR mdv1_PTR_GEN
200 LRESPR mdv1_WMAN
300 LRESPR mdv1_HOT_REXT
400 PROG_USE mdv1_
500 DATA_USE mdv2_
510 LRESPR turbo_tk

This time I crash on boot.

Code: Select all

Terminate on signal 11
This may be due to an internal error,
a feature not emulated or an 68000 exception
that typically occurs only when QDOS is unrecoverably
out of control
FATAL error, PC may not be displayed correctly
DebugInfo: PC=7c880, code=4e43, SupervisorMode: no USP=7c7be SSp=28480 A7=7c7c6
Register Dump:    Dn      An
0            70          0
1             0      7b000
2          37c4      7c830
3      ffffffff          0
4          ceb8          1
5           800        a60
6             0      7b068
7             0      7c7c6
*** Error in `./qm': double free or corruption (out): 0x005892d8 ***
exiting


Tomas

Re: uQLx 2018a

Posted: Tue May 21, 2019 11:20 am
by XorA
Are you running uQlx as a 64bit compile? (there are some other issues noted elsewhere in forum in 64bit)

Did you compile the correct branch? (https://github.com/SinclairQL/uqlx-fork ... tree-64bit - this includes "fixes" even for 32bit)

Its been a while since I tested with PE.

Re: uQLx 2018a

Posted: Tue May 21, 2019 1:05 pm
by tcat
Hi Graemme,

Thank you for taking your interest. I compile for `uname -m' armv7l machine, which is RPI3 here.

I think it may fail to detect my older version of PE, V1.39, the very same I use on real thing QL.

I have also noticed, that other builds of `uqlx' when first run, they patch themselves, I would not know how to trigger self-patching with your build.

Many thanks.
Tomas