QPC hangs after <CTRL><ALT><SHIFT><TAB>

Discussion and advice about emulating the QL on other machines.
User avatar
tofro
QL Wafer Drive
Posts: 1595
Joined: Sun Feb 13, 2011 10:53 pm
Location: SW Germany

QPC hangs after <CTRL><ALT><SHIFT><TAB>

Postby tofro » Fri Feb 10, 2017 12:26 pm

Title says it all - I have a number of PCs that all run QPC 4.0x (x = 1 and 2) - Just was in the mood to test systematically this morning - All of them hang when I try to reset them with the SMSQ/E "4-Finger salute".
Is this only with my setup or has anyone else the same problem? It looks a bit symptomatic, after all it happens on 4 different PCs (even if they more or less use the same extensions).

Tobias


ʎɐqǝ ɯoɹɟ ǝq oʇ ƃuᴉoƃ ʇou sᴉ pɹɐoqʎǝʞ ʇxǝu ʎɯ 'ɹɐǝp ɥO
User avatar
dilwyn
Mr QL
Posts: 1495
Joined: Wed Dec 01, 2010 10:39 pm
Location: Wales
Contact:

Re: QPC hangs after <CTRL><ALT><SHIFT><TAB>

Postby dilwyn » Fri Feb 10, 2017 6:10 pm

I use QPC2 v4.05 on a Windows 7 PC and an old XP laptop and the four finger salute works fine for me, at least.

Hopefully your computers don't have C-Sh-Alt-TAB set up as hotkeys or anything to do something elsewhere on the computers?


Dilwyn
All things QL: see www.dilwyn.me.uk
User avatar
mk79
Gold Card
Posts: 363
Joined: Sun Feb 02, 2014 10:54 am

Re: QPC hangs after <CTRL><ALT><SHIFT><TAB>

Postby mk79 » Sat Feb 11, 2017 11:47 am

tofro wrote:Title says it all - I have a number of PCs that all run QPC 4.0x (x = 1 and 2)
Why not the latest version, 4.05? It's difficult to support old versions.
Just was in the mood to test systematically this morning - All of them hang when I try to reset them with the SMSQ/E "4-Finger salute".
Hang means complete hang? Did you try it without any boot file?

Never heard of any problem regarding this. 4.02 introduced some special low level keyboard code that captured the key combination before it reaches Windows because ALT+SHIT+TAB is the task switcher and on certain versions it was also triggered by CTRL+ALT+SHIFT+TAB. Can't reproduce it anymore, so it seems they fixed it, but even then is just switched tasks and didn't hang.

All the best, Marcel


User avatar
tofro
QL Wafer Drive
Posts: 1595
Joined: Sun Feb 13, 2011 10:53 pm
Location: SW Germany

Re: QPC hangs after <CTRL><ALT><SHIFT><TAB>

Postby tofro » Sat Feb 11, 2017 12:53 pm

Marcel,

happens with 4.05 as well.

Note - I'm not blaming QPC, but rather ask what the reasons could be.

And, yes, it doesn't freeze when I start with no or an empty BOOT file. Apparently, something is in there that collides with the Reset routines. As my BOOT is pretty large, I'm rather looking for hints where I should start to look.

Tobias


ʎɐqǝ ɯoɹɟ ǝq oʇ ƃuᴉoƃ ʇou sᴉ pɹɐoqʎǝʞ ʇxǝu ʎɯ 'ɹɐǝp ɥO
Derek_Stewart
QL Wafer Drive
Posts: 1409
Joined: Mon Dec 20, 2010 11:40 am
Location: Runcorn, Cheshire, UK

Re: QPC hangs after <CTRL><ALT><SHIFT><TAB>

Postby Derek_Stewart » Sat Feb 11, 2017 2:04 pm

Hi,

The CTL-ALT-SHIFT-TAB bring a cycle of applications in Linux Mint, which is defined in the operating system shortcut keys.

I always used to use ALT-F1 as the Button Sleep, but ALT F1 in Linux Mint is defined as a shortcut key, refining this definition allowed the emulator to to work as normal.

Though I started used ALT-z for Sleep Button, seemed like a lot of z z z z is required sometimes.

This works the same way in Windows, just redeine the Windows Short Cut Key definition.


Regards,

Derek
User avatar
tofro
QL Wafer Drive
Posts: 1595
Joined: Sun Feb 13, 2011 10:53 pm
Location: SW Germany

Re: QPC hangs after <CTRL><ALT><SHIFT><TAB>

Postby tofro » Sat Feb 11, 2017 3:23 pm

OK. Found it. Firt upgraded one PC to the newest QPC from Marcel's site - Same problem.

Then started to comment out stuff from the BOOT file - I was lucky the offender was one of the first instructions in there...

And after having found the problem, I am not sure if I really should not blame QPC for it :)

The problematic line in my BOOT file was apparently an EPROM_LOAD of the Prospero Pascal runtime library EPROM. Once that is removed, everything seems to work fine, 4 Fingers will reliably reset SMSQ/E.

That ROM file is a straightforward dump of the Prospero Pascal ROM that wants to be located in the ROM slot memory area - Even if I load this manually (after BOOT has finished), it works fine, (ProPascal runs and finds it, the EPROM check command PRL verifies it properly) but makes QPC hang as soon as I use my 4 fingers. Everything but the 4-finger-reset works well.

And hang means, well, hang. Mouse pointer vanishes, SysMon stops, as if the OS had gone into an endless loop (QPC at 50% load on a two-core emulated CPU). Reproduced on a Mac using Parallels and Win7, a "plain old" Sony laptop using Win7 and a Linux box running QPC in Wine.

I did a quick check on whether the Pascal ROM does anything suspicious to the system (using Disa ;) )and that didn't reveal anything. Another check with an EPROM_LOAD of an old TK2 ROM shows the same effect - Hang on reset, otherwise everything fine. Apparently, EPROM_LOAD doesn't seem to work properly..

Tobias
Last edited by tofro on Sun Feb 12, 2017 8:11 am, edited 1 time in total.


ʎɐqǝ ɯoɹɟ ǝq oʇ ƃuᴉoƃ ʇou sᴉ pɹɐoqʎǝʞ ʇxǝu ʎɯ 'ɹɐǝp ɥO
swensont
Forum Moderator
Posts: 155
Joined: Tue Dec 06, 2011 3:30 am
Location: SF Bay Area
Contact:

QPC hangs after <CTRL><ALT><SHIFT><TAB>

Postby swensont » Sun Feb 12, 2017 5:34 am

Does Pro Pascal run on QPC? It runs fine with Q-emultor and UQLX, but I've had issues getting it to run with SMSQmulator, so I'm not sure it works well with SMSQ/E.

BTW, it is nice seeing someone else using Pro Pascal.

Tim Swenson


User avatar
tofro
QL Wafer Drive
Posts: 1595
Joined: Sun Feb 13, 2011 10:53 pm
Location: SW Germany

Re: QPC hangs after <CTRL><ALT><SHIFT><TAB>

Postby tofro » Sun Feb 12, 2017 7:28 am

swensont wrote:Does Pro Pascal run on QPC?


It runs perfectly well after a bit of tweaking and builds nice, fast and small programs. I might do a writeup how to make it run once I come around to it.

Tobias


ʎɐqǝ ɯoɹɟ ǝq oʇ ƃuᴉoƃ ʇou sᴉ pɹɐoqʎǝʞ ʇxǝu ʎɯ 'ɹɐǝp ɥO
User avatar
mk79
Gold Card
Posts: 363
Joined: Sun Feb 02, 2014 10:54 am

Re: QPC hangs after <CTRL><ALT><SHIFT><TAB>

Postby mk79 » Sun Feb 12, 2017 4:59 pm

tofro wrote:OK. Found it. Firt upgraded one PC to the newest QPC from Marcel's site - Same problem.

Then started to comment out stuff from the BOOT file - I was lucky the offender was one of the first instructions in there...

And after having found the problem, I am not sure if I really should not blame QPC for it :)
Well, you can ;) Well, actually, you can blame the ATARI as well, because I copied the memory table over from the Atari version of SMSQ/E and that one has a slice starting at $FFFC instead of $10000... that long word at $FFFC is not important unless you do a reset. It should be fixed in the next SMSQ/E release.

Thanks, Marcel



Who is online

Users browsing this forum: No registered users and 2 guests