Some useful commands and info.

Helpful tips and guides, also new users can ask for help here.
RWAP
RWAP Master
Posts: 2494
Joined: Sun Nov 28, 2010 4:51 pm
Location: Stone, United Kingdom
Contact:

Re: Some useful commands and info.

Postby RWAP » Sun Mar 20, 2011 4:20 pm

OK - so what is the issue with the disk controllers (no memory involved on these).

You could really do with upgrading to QJUMP ROMs for these as well - to avoid using DIR fdk1_ instead of DIR flp1_

It is most probably the WD1770 controllers, although the DIP switches on the one interface look wrong - see the recently uploaded manual on the Sinclair QL Homepage - http://www.dilwyn.me.uk/docs/manuals/mi ... erface.pdf


User avatar
Mr_Navigator
QL Fanatic
Posts: 782
Joined: Mon Dec 13, 2010 11:17 pm
Location: UK, Essex
Contact:

Re: Some useful commands and info.

Postby Mr_Navigator » Sun Mar 20, 2011 9:56 pm

Well the first thing is the interface with the dip switches, took me awhile to realise that the switch has been replaced with a R.S. Components unit and was upside down so all the switch positions where AAF.

Having sorted that out I managed to get the floppy disk turning when typing in DIR FDK1_ sometimes I would get a directory listing, but no program will run as I get the error "drive not ready" when trying to load a program. Formatting the disk in the drive, I get the same error, it starts for about a second then "drive not ready". Have tried different drives both old and new and get the same error. Changed the interface for the other version which has no dip switches, exactly the same error. Any ideas?


-----------------------------------------------------------------------------------
QLick here for the Back 2 the QL Blog http://backtotheql.blogspot.co.uk/
RWAP
RWAP Master
Posts: 2494
Joined: Sun Nov 28, 2010 4:51 pm
Location: Stone, United Kingdom
Contact:

Re: Some useful commands and info.

Postby RWAP » Mon Mar 21, 2011 9:16 am

OK - this could be the WD1770 controller chips.

However, first of all need to check out the basics...

a) Are you using DD disk drives and DD disks? If not, have you taped over the HD detection hole in the floppy disks?

b) Are the disk drives PC standard drives, or QL specific floppy disk drives?

c) Is the cable to the disk drive untwisted (straight) without any wires swapped over - a PC floppy disk drive will NOT work !

d) Do the disk drives have jumpers on them or a solder pad, to allow you to set them up as DS0 (master) (FLP1_ or FDK1_) - remember that PC floppy disk drives are shipped as DS1 (slave) and will not work with the QL in this manner. Some DS1 drives will work if you swap pins 10 and 12 on the floppy disk cable

e) When you connect the disk drive to the QL, does the light come on constantly / disk turn constantly? If so, then the cable is upside down.

I think it is more likely to be an issue with the disk drives...

All these things to investigate and people wonder why I charge £90 for a set of dual externally cased DD floppy disk drives for the QL, even though they are second hand - it normally takes a couple of hours or more to get disks working (if you can find two disk drives that match and work together!).


User avatar
Mr_Navigator
QL Fanatic
Posts: 782
Joined: Mon Dec 13, 2010 11:17 pm
Location: UK, Essex
Contact:

Re: Some useful commands and info.

Postby Mr_Navigator » Mon Mar 21, 2011 5:57 pm

They are PC drives and yes the link is on DS0, and cable untwisted and also works perfectly well with the PCML interface I got from SellMyRetro( :lol: ), however changing to either of the two Micro-Peripherals gets the time error, I will go through the whole process tonight to check and note each stage.


Ok, just tested again and this is what happens, all connected up, switch on the power to the drive, motor gives a little twitch, power op QL and floppy disk drive runs with the floppy inside it 720K type until the power up process has finished with the copyright message is displayed at this point the drive stops.

Pressing the F2 the mdv1_ spins and comes to a stop, no reaction from FDK1_
typing in DIR FDK1_ the drive spins up, led comes on for a second or two and then the message as below

photo 0.JPG


Sometimes the DIR command gives a slightly different result

photo1.JPG


The disk is still PC formatted so the command Format FDK1_test is tried and then FORMAT FDK1_ is tried both with the same result

photo2.JPG


I have tried the disk and interface with a formatted disk and sometime get a directory with DIR FDK1_ and sometimes not, I have been able to load a small boot (two lines) SuperBasic program from a RWAP made disk but running the boot program which then loads the bigger machine code file doesn't get very far as the same error as shown above occurs. :cry:


-----------------------------------------------------------------------------------
QLick here for the Back 2 the QL Blog http://backtotheql.blogspot.co.uk/
RWAP
RWAP Master
Posts: 2494
Joined: Sun Nov 28, 2010 4:51 pm
Location: Stone, United Kingdom
Contact:

Re: Some useful commands and info.

Postby RWAP » Mon Mar 21, 2011 9:46 pm

The original MicroP ROM did not boot from FLP1_ unless you changed one of the jumpers (as per manual lol).

It could well be the drive is just too fast for the MicroP disk interface (yes I have come across that issue also!).

The other thing to try might be to use the WD1770 controller chip out of the PCML interface and try it in a MicroP interface - see what happens (although it may be soldered into the PCML interface...) If it is, I have an interface here with a socketed WD1770 which you could borrow....

Talking of disks, I have a single sided double density 3.5" disk here which is QL formatted, but I can't read !! Fancy having a go with that as well?


User avatar
Mr_Navigator
QL Fanatic
Posts: 782
Joined: Mon Dec 13, 2010 11:17 pm
Location: UK, Essex
Contact:

Re: Some useful commands and info.

Postby Mr_Navigator » Mon Mar 21, 2011 10:36 pm

Yes please will borrow and look at the disk as well, my PCML disk interface is soldered directly to the board here https://picasaweb.google.com/lee.privett/PCMLFloppyDiskInterface#5581076412075072194


are the WD1770 chips not available anymore?

Here's an interesting one, I placed a 500K Expanderam in the QL first then the MP disk interface and when trying to format the floppy disk, the light comes on, the disk turns but no movement is heard from the read/write head, however it seems to format forever or at least 20 minutes before I have to reset the QL ( I suppose it locks up). No time out! no error, and no formatted disk. :cry:

This makes interesting reading though http://www.devili.iki.fi/Computers/Commodore/C1581/Service_Manual/Page_09.html


-----------------------------------------------------------------------------------
QLick here for the Back 2 the QL Blog http://backtotheql.blogspot.co.uk/

Return to “Help for New Users”

Who is online

Users browsing this forum: No registered users and 1 guest