Search found 42 matches

by Bloodnok
Tue Jan 28, 2020 10:21 pm
Forum: Hardware
Topic: vDrive QL format error
Replies: 2
Views: 467

Re: vDrive QL format error

Hi, I've also replied on SMR. In the meantime I'll need a few details: 1. QL board issue 2. After the format failure, enter VINFO and report if there is any error code listed 3. I expect this has already been done, but check the cable and clean the connectors. 4. Copy a known MDV image (you can get ...
by Bloodnok
Thu Nov 21, 2019 11:40 pm
Forum: Hardware
Topic: vDrive ZX: emulated ZX Microdrive
Replies: 31
Views: 8063

Re: vDrive ZX: emulated ZX Microdrive

I think the OPD Microdrives are significantly different. Don't they run at a different speed? The drives are physically the same and the tape runs at the same speed. The data rate is also the same but the sector format is different. No reason the vDrive wouldn't work but would require the sector fo...
by Bloodnok
Tue Aug 20, 2019 12:08 am
Forum: Hardware
Topic: Microdrives dont spin or do anything
Replies: 15
Views: 2804

Re: Microdrives dont spin or do anything

Tada! I finally got my Vdrive QL working! It was my Vmap that caused my problems and Charlie is sending me a new one. IMG_4008.jpg IMG_4010.jpg Just to clarify - the vMap was damaged during installation - it is definitely a challenge to fit but I think that's made clear in the install guide. I have...
by Bloodnok
Tue Aug 20, 2019 12:04 am
Forum: Hardware
Topic: Microdrives dont spin or do anything
Replies: 15
Views: 2804

Re: Microdrives dont spin or do anything

Hi Bill! The fact that you can 'see' the 'VTKQL109' medium listed suggests that the vDrive is being correctly accessed - but as yet, does not recognise the SD Card. If I recall correctly from the vDrive documentation and my own experience, vDrive will present a 'pseudo' MDV image containing only a ...
by Bloodnok
Mon Aug 19, 2019 11:35 pm
Forum: Hardware
Topic: Reset Switch
Replies: 6
Views: 1262

Re: Reset Switch

I have my QL almost 100% When you press the reset switch nothing happens. I sprayed contact cleaner and waited a few hours and still doesn't work. Anyone have any ideas? Cheers! Bill Hi Bill, from the photo your sent me the reset switch has certainly been damaged. I suggested trying to press the sw...
by Bloodnok
Wed Aug 14, 2019 10:38 pm
Forum: Hardware
Topic: Microdrives dont spin or do anything
Replies: 15
Views: 2804

Re: Microdrives dont spin or do anything

Hi Bill. As Rich has mentioned mdv1_ may be unplugged or faulty (or the 8302 ULA may be faulty -SellMyRetro still has spares). Best to just install the vMap as this provides independent addressing for the internal drives and the external bus. You'll be having to open the QL anyway so may as well ins...
by Bloodnok
Sun Aug 11, 2019 10:39 pm
Forum: Hardware
Topic: Mod on ULA
Replies: 9
Views: 2225

Re: Mod on ULA

Thanks Nasta, mystery solved (I've always wondered why RAW was used on the QL and not just DATA as in the Spectrum). It is a mandatory mod then - quite a few QL's I come across in supporting the vDriveQL don't have the mod so I'll be recommending it be added.
by Bloodnok
Thu Aug 08, 2019 11:11 pm
Forum: Hardware
Topic: Mod on ULA
Replies: 9
Views: 2225

Re: Mod on ULA

The two 33K resistors appear to work as a mild pull-down on the two data lines for the Microdrive bus. The presence or absence of this mod does not appear to affect vDriveQl performance and what the mod is trying to fix is a mystery. I've been working with Andrew on a fix for the 'vDrive not respond...
by Bloodnok
Fri Aug 17, 2018 5:16 am
Forum: Software & Programming
Topic: How to get The Pawn up and running with the vDriveQL
Replies: 0
Views: 1268

How to get The Pawn up and running with the vDriveQL

If you've got a vDriveQL and would like to play The Pawn adventure game then here's what to do: Due to the need to swap cartridges in mdv1_ and mdv2_ during game loading, and not being able to return to the command line to change the vDriveQL config using the vDriveQL toolkit, two SD cards are neede...
by Bloodnok
Thu Jan 04, 2018 5:58 pm
Forum: Hardware
Topic: Tetroid Disk Interface - FORMAT issue
Replies: 12
Views: 3731

Re: Tetroid Disk Interface - FORMAT issue

The problem shows up when using the FORMAT ram1_mdv1 command to copy an entire Microdrive cartridge to ram drive. The Microdrive content appears to transfer OK but the files are corrupt in the ram drive (reading them back fails). The command works OK in versions of the Trump card firmware prior to 2...