SDC/WIN driver and curious RENAME behaviour...

Anything QL Software or Programming Related.
Gold Card
Posts: 351
Joined: Sat Oct 25, 2014 9:53 am

SDC/WIN driver and curious RENAME behaviour...

Postby martyn_hill » Sun Jan 28, 2018 4:53 pm

Hi everyone

Thanks to Wolfgang for his work on porting the WIN driver to QDOS and merging with the SDC driver.

As a result, I am now able to mount a number of .WIN container files as WIN1_, WIN2_ etc and in the process, ease the transfer of files from QPC to my QL(s).

Loving it!

One curiosity that I have spotted which worked as expected with the original QubIDE/SDC driver but now throws an error is use of RENAME. I'll post this to the QL-Users list as well as WL tends to hang-out there more than here, but for the record (and to solicit any feedback...):

Using my home-brew file-transfer app, I moved a file over to the QL, as I do all the time from QPC. The app captures the file-fragments via the SERial port in to a temporary file and, once the transfer is complete, renames the tmp file to its final resting place on the SD Card, with a given name.
The following worked fine under QubIDE/SDC, but errors-out with the WIN/SDC driver (all else being equal):

RENAME tmpFile$ TO targetPth$ & fileName$

The variables in question in this case were:

tmpFile$ = 'sdc1_tmp_1801281611'
targetPath$ & fileName$ = 'sdc1_RMS_RMS_v4t4k_exe'

A WIN_USE 'sdc' appears in my Boot file, prior to running this app.
The error reported under WIN/SDC is 'bad name' and appears the same whether using RENAME from the command line with explicit names in place of the variables and even trying WREN in pace of RENAME.
I can COPY the tmp file to its new name without problem (i.e. replacing RENAME with COPY and keeping the rest as-is.) I can then delete the original file manually as well.
When using WREN, the expected 'Do you want to copy xxx to yyy' prompt appears and the error appears only after accepting with 'Y'.
The first 'RMS_' in the target file-path is a hard directory on SDC1_.
I'm running Minerva v1.98 on this QL, with the WIN/SDC driver burnt in to the usual 16k ROM slot at 0c000.

Any thoughts?

Gold Card
Posts: 351
Joined: Sat Oct 25, 2014 9:53 am

Re: SDC/WIN driver and curious RENAME behaviour...

Postby martyn_hill » Mon Jan 29, 2018 2:38 pm

Well... true to form, within hours of reporting the issue, Wolfgang has delivered a fix for me to test - and it works!

I can now successfully RENAME files with the WIN driver on SDC.

Apparently, there was a little glitch in how the default WIN_USE mapping to MDV had been set in the driver.

I understand that it may be another 24hours or so before he gets around to uploading the fixed version to the original site.

Thank you WL!

Return to “Software & Programming”

Who is online

Users browsing this forum: No registered users and 2 guests