ULA ZX8301 - TV Picture Capabilities

Nagging hardware related question? Post here!
tcat
Gold Card
Posts: 449
Joined: Fri Jan 18, 2013 5:27 pm
Location: Prague, Czech Republic

Re: ULA ZX8301 - TV Picture Capabilities

Postby tcat » Sat Sep 09, 2017 7:53 am

Hi All,

I am trying to catch up with the posts after holiday. It sounded here that from Issue 5 to Issue 6 transition, HAL was introduced to take care of address decode, originally task of ZX8301, so on Issue 6 boards there is a dangling unused pin on ZX8301. Interestingly just one pin ZX8301 was short of, and missed in the original QL, to drive 16 colours, now free and unused :-)

My QL Issue 6, suffers flair in white colour when in TV mode and connected UHF cable to the Television. My question here is, what is the reason, and how can it be rectified?

I have tried deoxydising pins of PAL chip, also I have got a spare PAL chip from RWAP to experiment with (Thank you Rich).
Could it be that all Issue 6 boards suffer this flair in white, because of introduction of HAL and leaving out one pin in ZX8301?

Can anyone explain?
Many thanks
Tomas
Last edited by tcat on Sun Sep 10, 2017 9:09 am, edited 3 times in total.


Martin_Head
Gold Card
Posts: 270
Joined: Tue Dec 17, 2013 1:17 pm

Re: ULA ZX8301 - TV Picture Capabilities

Postby Martin_Head » Sat Sep 09, 2017 10:38 am

It could be the UHF modulator playing up. Do you get the same problem with the composite video output?

Does it do the same on another TV? It could be a problem with the TV? I remember that on some old televisions, flaring on peak whites was a sign of the CRT getting old.


tcat
Gold Card
Posts: 449
Joined: Fri Jan 18, 2013 5:27 pm
Location: Prague, Czech Republic

Re: ULA ZX8301 - TV Picture Capabilities

Postby tcat » Sat Sep 09, 2017 6:31 pm

Hi Martin,

My TV is quite a modern Thomson make, it gives excellent picture with ZX Speccy and ATARI ST, all in TV mode, no flair in white.
QL Picture over RGB-SCART cable is also perfect.

I can try replacing PAL chip, though.

Should it were the UHF modulator, I wonder what could be wrong with it, as it consists of some resistors, ceramic capacitors, a transistor, and there is one ferit adjustment coil. Could it be retuned, because some elyt capacitors drying out in years, those on 12V, assuming here UHF modulator needs a good and smooth 12V source?

I am not much wiser, seeking help and advice, all greatly apreciated.

Many thanks.
Tom


Martin_Head
Gold Card
Posts: 270
Joined: Tue Dec 17, 2013 1:17 pm

Re: ULA ZX8301 - TV Picture Capabilities

Postby Martin_Head » Mon Sep 11, 2017 11:03 am

If I remember rightly, In the UHF television signal, the bottom of the sync pulses (blacker than black) is the maximum carrier amplitude. And peek white is minimum carrier amplitude. So if you supplied too big a signal (or it thought it was too big a signal) you could effectively stop the carrier which would 'crush' the peek whites.

It could be that one of the components in the modulator has 'aged'. I think if I was trying to repair the modulator, I would first change the transistor, and while it was out check the values of all the resistors.

I suspect that if you adjust the coil, it will change the channel number (usually channel 36)

I'm pretty sure that the UHF modulator in the QL is the same one as in the Spectrum/ZX81. Here is a link https://www.petervis.com/electronics%20guides/UHF_Modulator/UHF_Modulator.html to a circuit of a UHF Modulator. I don't know if it's the Aztec one.


tcat
Gold Card
Posts: 449
Joined: Fri Jan 18, 2013 5:27 pm
Location: Prague, Czech Republic

Re: ULA ZX8301 - TV Picture Capabilities

Postby tcat » Mon Sep 11, 2017 2:21 pm

Hi Martin,

Thank you. It seems AZTEC modulator found in both ZX and QL. I have looked up the transistor 2N2222 in a local electronics shop.
With the specs below, hFe gain is not given, I guess what matters here is the frequency capability here.

Code: Select all

/ FAIRCHILD / NXP
NPN 40V/ 0,60A/ 0,62W/ >250MHz (= KSP2222A, PN2222A) TO92 E B C 7a


I may expect pin orientation may not be the exact match with the transistor used inside UHF modulator, here it is EBC, right?

Many thanks
Tomas


User avatar
NormanDunbar
Gold Card
Posts: 364
Joined: Tue Dec 14, 2010 9:04 am
Location: Leeds, West Yorkshire, UK
Contact:

Re: ULA ZX8301 - TV Picture Capabilities

Postby NormanDunbar » Mon Sep 11, 2017 8:21 pm

Here's the Hfe details for a 2n2222A that I'm using for Arduino and Raspberry Pi stuff - when I get a chance.

Code: Select all

Test Condition           Min   Max
Ic = 0.1mA, Vce = 10V     35
Ic = 1mA,   Vce = 10V     50
Ic = 10mA,  Vce = 10V     75
Ic = 150mA, Vce = 10V    100   300 (Note 1)
Ic = 150mA, Vce = 1V      50       (Note 1)
Ic = 500mA, Vce = 10V     40       (Note 1)


Note 1 says: Pulse test: tp ≤ 300μs , δ ≤ 2%


These are in a metal can, TO-18 package format, and the pinout, looking at the underside, is as follows:

Code: Select all

    C E
     B


The tab on the TO-18 package is closest to the Emitter.


HTH

Cheers,
Norm.


Why do they put lightning conductors on churches?
How come Tarzan never grew a beard?
tcat
Gold Card
Posts: 449
Joined: Fri Jan 18, 2013 5:27 pm
Location: Prague, Czech Republic

Re: ULA ZX8301 - TV Picture Capabilities

Postby tcat » Tue Sep 12, 2017 12:02 pm

Hi Martin,

Although in Hungarian, the schematics shows AZTEC modulator UM1233, the same model matching QL Issue#6 wiring diagram. It has got three transistors BF199. Any of those can qualify for replacement?

In the QL diagram, there is smoothing elyt 100uF to supply modulator with 5V, not sure if it can have any influence on white flair, but perhaps is also worth inspecting or replacing?

I am also thinking to let temporarily ZX8301 drive address decode, and disabling HAL doing that, defacto downgrading to Issue#5 logic, to see any influence on TV picture quality, not sure what has to be done, bending a pin on HAL and laying a piece of wire from ZX8301? If not too silly an idea?

Many thanks
Tomas


Nasta
Trump Card
Posts: 204
Joined: Sun Feb 12, 2012 2:02 am
Location: Zapresic, Croatia

Re: ULA ZX8301 - TV Picture Capabilities

Postby Nasta » Tue Sep 12, 2017 10:54 pm

Before the next post becomes 'help, my QL stopped working!':
8301 PCENL decoding has nothing whatsoever to do with the RGB output. It's not 8301 decoding that is handled by the HAL but 8302, and that chip has nothing to do with the video. There are more subtle and not subtle differences in pre-HAL and HAL boards, how did you discern that it must be the HAL that is the problem? As the old saying goes: correlation does not imply causation.
Try lowering the composite output amplitude before the input of the modulator, or providing better power decoupling - which is a problem for many parts of the QL motherboard.


tcat
Gold Card
Posts: 449
Joined: Fri Jan 18, 2013 5:27 pm
Location: Prague, Czech Republic

Re: ULA ZX8301 - TV Picture Capabilities

Postby tcat » Wed Sep 13, 2017 8:25 am

Hi Nasta,

Thank you, I was hoping for and awaiting your comment, too :-)

Now again studying `QL Service Manual' and Issue#6 diagram. It says composite PAL signal is output/divided to UHF Modulator, capturing in the picture, when you say lowering amplitude, you mean changing values of the resistors R85/R86, how?
PAL-UHF-feed.png
Composite PAL feed to UHF modulator

Could it also be some of the modulators' transistors being degraded, worth replacing?


Many thanks so far.
Tomas



Return to “Hardware”

Who is online

Users browsing this forum: No registered users and 3 guests