Sinclair Retro BBS online!

A collection of QL services and websites.
User avatar
Outsoft
Super Gold Card
Posts: 572
Joined: Sat Apr 19, 2014 1:30 pm
Location: Italy
Contact:

Re: Sinclair Retro BBS online!

Postby Outsoft » Fri May 26, 2017 9:58 am

Dave wrote:What are the characters you're getting? They might give us a clue if it is a bit error or something else.

My first instinct is to suspect IC25, the 1488, receiving noise from the 8302. That's where I'd start looking. I have a logic analyzer and that's the first place I'd look. Either the 1488 is noisy for some reason, or it is cleanly converting an input from the 8302.


I will send a photo.

The characters are not letters but all simbols that it doesn't exist on the QL character set.

Thanks for check.


User avatar
Outsoft
Super Gold Card
Posts: 572
Joined: Sat Apr 19, 2014 1:30 pm
Location: Italy
Contact:

Re: Sinclair Retro BBS online!

Postby Outsoft » Fri May 26, 2017 10:06 am

Dave wrote:What are the characters you're getting? They might give us a clue if it is a bit error or something else.

My first instinct is to suspect IC25, the 1488, receiving noise from the 8302. That's where I'd start looking. I have a logic analyzer and that's the first place I'd look. Either the 1488 is noisy for some reason, or it is cleanly converting an input from the 8302.


There is something that I can do externally? An "anti noise" that I can put near the zone (without open the QL) and see If this will make the disturb be many frequent?

I see that when the QL is "hot" (I mean powered on for 30 minutes) the Serial ISTANTLY sent these bad characters, instead when is COLD...It need 20/30 mintes to start.

So all depends on it ;)


User avatar
Outsoft
Super Gold Card
Posts: 572
Joined: Sat Apr 19, 2014 1:30 pm
Location: Italy
Contact:

Re: Sinclair Retro BBS online!

Postby Outsoft » Fri May 26, 2017 10:12 am

Dave wrote:What are the characters you're getting? They might give us a clue if it is a bit error or something else.

My first instinct is to suspect IC25, the 1488, receiving noise from the 8302. That's where I'd start looking. I have a logic analyzer and that's the first place I'd look. Either the 1488 is noisy for some reason, or it is cleanly converting an input from the 8302.


A friend got a similar problem (a block on 1 Network port on his QL) and It solved changing the ULA.

Can be a similar problem too?



Return to “Links to QL Services and Websites”

Who is online

Users browsing this forum: No registered users and 1 guest